RC2-CBC-Parameter::=SEQUENCE{
rc2ParameterVersionINTEGEROPTIONAL,
ivOCTETSTRING(SIZE(8))
}
rc5-CBC-PADOBJECTIDENTIFIER::={encryptionAlgorithm9}
RC5-CBC-Parameters::=SEQUENCE{
versionINTEGER{v1-0(16)}(v1-0),
roundsINTEGER(8..127),
blockSizeInBitsINTEGER(64128),
ivOCTETSTRINGOPTIONAL
}
END
知识产权考虑
RSASecuritymakesnopatentclaimsonthegeneralconstrUCtions
describedinthisdocument,althoughspecificunderlyingtechniques
maybecovered.Amongtheunderlyingtechniques,theRC5encryption
algorithm(AppendixB.2.4)isprotectedbyU.S.Patents5,724,428
[22]and5,835,600[23].
RC2andRC5aretrademarksofRSASecurity.
Licensetocopythisdocumentisgrantedprovidedthatitis
identifiedasRSASecurityInc.Public-KeyCryptographyStandards
(PKCS)inallmaterialmentioningorreferencingthisdocument.
RSASecuritymakesnorepresentationsregardingintellectualproperty
claimsbyotherparties.Suchdeterminationistheresponsibilityof
theuser.
修订记录
Versions1.0-1.3
Versions1.0-1.3被分发给在1991年1月和3月参加RSAData
SecurityInc.的公钥密码系统标准会议的与会者 。
Version1.4
Version1.4是1991年6月3日PKCS的首次发行的一部分 。该版本作为NIST/OSI
Implementors"Workshop文档SEC-SIG-91-20出版 。.
Version1.5
Version1.5综合了几处编辑更正,包括对参考书目的修改和修订记录的增加 。
Version2.0
Version2.0综合了文档结构方面的主要编辑更正,并引入了PBES2加密方法,PBMAC1消
息认证方法,和独立的基于口令的密钥导出函数 。该版本继续支持版本1.5中的加密过程 。
参考书目
[1]AmericanNationalStandardX9.52-1998,TripleDataEncryption
AlgorithmModesofOperation.Workingdraft,Accredited
StandardsCommitteeX9,July27,1998.
[2]Baldwin,R.andR.Rivest,"TheRC5,RC5-CBC,RC5-CBC-Pad,and
RC5-CTSAlgorithms",RFC2040,October1996.
[3]Balenson,D.,"PrivacyEnhancementforInternetElectronicMail:
PartIII:Algorithms,Modes,andIdentifiers",RFC1423,
February1993.
[4]S.M.BellovinandM.Merritt.Encryptedkeyexchange:
PassWord-basedprotocolssecureagainstdictionaryattacks.In
Proceedingsofthe1992IEEEComputerSocietyConferenceon
ResearchinSecurityandPrivacy,pages72-84,IEEEComputer
Society,1992.
[5]D.Jablon.Strongpassword-onlyauthenticatedkeyexchange.ACM
ComputerCommunicationsReview,October1996.
[6]Kaliski,B.,"TheMD2Message-DigestAlgorithm",RFC1319,April
1992.
[7]Krawczyk,H.,Bellare,M.andR.Canetti,"HMAC:Keyed-Hashing
forMessageAuthentication",RFC2104,February1997.
[8]RobertMorrisandKenThompson.Passwordsecurity:Acase
history.CommunicationsoftheACM,22(11):594-597,November
1979.
[9]ISO/IEC8824-1:1995:Informationtechnology-AbstractSyntax
NotationOne(ASN.1)-Specificationofbasicnotation.1995.
[10]ISO/IEC8824-1:1995/Amd.1:1995Informationtechnology-Abstract
SyntaxNotationOne(ASN.1)-Specificationofbasicnotation-
Amendment1-Rulesofextensibility.1995.
[11]ISO/IEC8824-2:1995Informationtechnology-AbstractSyntax
NotationOne(ASN.1)-Informationobjectspecification.1995.
[12]ISO/IEC8824-2:1995/Amd.1:1995Informationtechnology-Abstract
SyntaxNotationOne(ASN.1)-Informationobjectspecification-
Amendment1-Rulesofextensibility.1995.
[13]ISO/IEC8824-3:1995Informationtechnology-AbstractSyntax
NotationOne(ASN.1)-Constraintspecification.1995.
[14]ISO/IEC8824-4:1995Informationtechnology-AbstractSyntax
NotationOne(ASN.1)-ParameterizationofASN.1specifications.
1995.
[15]NationalInstituteofStandardsandTechnology(NIST).FIPSPUB
46-2:DataEncryptionStandard.December30,1993.
[16]NationalInstituteofStandardsandTechnology(NIST).FIPSPUB
81:DESModesofOperation.December2,1980.
[17]NationalInstituteofStandardsandTechnology(NIST).FIPSPUB
- 基于MPLS的流量工程要求
- Linux下基于DNS的多机均衡负载的实现
- 光以太网基于LAN的WAN
- 支付宝吱口令怎么关闭 停用当前吱口令的方法介绍
- 微信中发语音口令红包具体操作方法
- 基于H.323标准的IP电话附加业务
- 基于VoIP技术的新一代话音业务
- 基于分组网的多媒体视听业务的发展
- 报花名绕口令 绕口令的相关知识
- 支付宝口令红包怎么领取
